Xcode8에서 Xcode7의 플러그인을 사용하는 방법

2016-09-27
25 Views

Xcode8에서는 이전버전까지 사용하던 플러그인들을 사용할 수 없다. 대신 Xcode Editor Extensions을 사용해야 하지만 아직까지는 크게 지원하지 않기 때문에 이전 플러그인들을 사용하는 방법을 소개한다.

update_xcode_plugins

설치하기 

dry-run 테스트해보기

실행하기

위와 같이 실행하면 플러그인들이 업데이트된다. 그렇지만 일부 플러그인들은 실행되지 않을 수 있다.

설치된 Xcode가 표시되므로 대상 Xcode에서 Yes를 한다. Unsign xcodebuild too?라는 질문은 No로 한다. 이렇게 해서 결과물이 나오면  Xcode-unsigned.app이 만들어지고 이를 이용해서 플러그인을 사용할 수있다.

Xcode를 다시 시작

다시 시작하면 Load Bundles경고창이 나오면 Load한다.

 

Facebook Comments

You may be interested

모바일 앱 아키텍처
Swift
shares13 views
Swift
shares13 views

모바일 앱 아키텍처

MJ Kim - 4월 22, 2017

이 내용은 나름대로 개발해본 내용을 토대로 정리해본 모바일 앱 아키텍처에 대한 내용이다. 이를 정리한 이유는 오래된 아키텍처부터 최근 아키텍처까지 정리해보고…

시간차를 얻는 Date Extension
Swift 3.0
shares6 views
Swift 3.0
shares6 views

시간차를 얻는 Date Extension

MJ Kim - 4월 12, 2017

사용자가 남길 내용에 대한 시간표시를 할 때 일정한 시간차를 표현해주는 경우가 있어 이에 대한 Date Extention을 정리해 보았다. [crayon-58fc64ce396b2439017955/]  

Swift 3.1에서 없어진 문법 정리
Swift 3.0
shares34 views
Swift 3.0
shares34 views

Swift 3.1에서 없어진 문법 정리

MJ Kim - 3월 31, 2017

Swift언어는 무엇인가 나올때마다 없어지는 것들이 있어, Swift 3.1에서 컴파일할 수 없게 된 문법내용을 정리했다. switch문을 사용하여 enum에서 protocol을 여러가지 패턴으로…