Swifter {Swift Developer}

메뉴

Xcode8에서 Xcode7의 플러그인을 사용하는 방법

Xcode8에서는 이전버전까지 사용하던 플러그인들을 사용할 수 없다. 대신 Xcode Editor Extensions을 사용해야 하지만 아직까지는 크게 지원하지 않기 때문에 이전 플러그인들을 사용하는 방법을 소개한다.

update_xcode_plugins

설치하기 

dry-run 테스트해보기

실행하기

위와 같이 실행하면 플러그인들이 업데이트된다. 그렇지만 일부 플러그인들은 실행되지 않을 수 있다.

설치된 Xcode가 표시되므로 대상 Xcode에서 Yes를 한다. Unsign xcodebuild too?라는 질문은 No로 한다. 이렇게 해서 결과물이 나오면  Xcode-unsigned.app이 만들어지고 이를 이용해서 플러그인을 사용할 수있다.

Xcode를 다시 시작

다시 시작하면 Load Bundles경고창이 나오면 Load한다.

 

Facebook Comments

카테고리:   Xcode

댓글

죄송하지만 댓글은 닫혀 있습니다.